You need to log in to create posts and topics.

NES Roms stopped working

I have been using the no-intro-collection NES roms on my device with no issues. Yesterday, I decided to clean up the roms to remove a bunch that I never play. I deleted all of the rom files from the NES roms folder using the RetroPie file manager, rebooted the device, and then I went through the standard process of installing new roms (put them on a flash drive in the NES roms folder within the automatically created RETROPIE folder system, plugged the flash drive into my device, let all the roms copy over, then rebooted the device). All of the roms show up in the list for NES; however, when I try to launch any of them, the screen goes dark for a couple seconds, then I am returned to the rom list.

These are the same rom files I was using previously, so my best guess is that maybe a config file was deleted or modified when I deleted the rom files using file manager (even though I only deleted rom .zip files).

I should also mention that I did the same exact thing with my SNES roms, but those are all working fine. It's only the NES roms that are no longer working.

Does anybody have any idea how to fix this?

So did you put NES roms on from that main no-intro collection that had links to all the different gaming systems? The NES files from that set are all headerless files and would behave like you described. Give this set a try and see if you have any better luck. Let me know.

That worked! Thanks so much for the help! Still loving your device.

Good to hear that worked and you are still loving it. Let me know if I can help out with anything else.